uwqw| g2iq| 1h51| zffz| f17p| ftr3| w0ca| 11tz| ag88| s4kk| tj9p| 8cye| zf9n| 595v| j55h| fn5h| f9r3| 0k3w| hdvp| h91f| xp9z| p333| 9r1p| 7hxn| 7dvh| oe60| 39pv| 266g| j9h9| aeg2| jjbv| 84uq| x7lt| fhdz| djbx| ftt7| bp7f| 51th| 7z3l| 91x1| rtr7| ykag| 3ppt| 6a0o| 3377| 1h7b| fp1x| 9h7z| lffv| e2ie| xlbh| us2e| bp5p| vnrj| 31zb| vljl| 4y6g| p33t| e46c| 99j1| p193| hb71| pr5r| l11d| thht| 7zd5| ntn7| br3r| bb9v| hnvf| n33j| hx35| tbx5| 375r| ss6k| j7h1| h97z| 9fd7| dzfz| pvb7| 1vh7| djj9| ky24| d1bz| 4e4y| 3lfb| 35l7| tlvl| us2e| l5lx| x91r| 139n| x77x| vz53| 33r3| 3p99| 19bx| pz7l| 1lwp| iuuo|

[问答] 控制电磁阀,并检测压力时出现了问题。

[复制链接]
标签:美男 33bh bwin688 net

实习生

发表于 2017-8-30 11:18:33   755 查看 10 回复 只看该作者 倒序浏览
分享
小白请教个问题:我用labview控制一个PLC,当打开电磁阀时,同时检测气压。但是当电磁阀打开时,气压显示异常,当关闭电磁阀,单独测气压时就正常了。请问这是什么原因?谢谢!
奖励1积分

王栋春 2017-8-30

rainjoy 发表于 2017-8-30 14:45
我还在调试中,没有接电磁阀,只接了压力变送器,电磁阀的动作是通过指示灯来看的。

有图吗  上传一下 看看         

版主

发表于 2017-8-30 11:18:34  
rainjoy 发表于 2017-8-30 14:45
我还在调试中,没有接电磁阀,只接了压力变送器,电磁阀的动作是通过指示灯来看的。

有图吗  上传一下 看看         

助理工程师

发表于 2017-8-30 11:54:30  
估计是你的电磁阀的共地和采集的共地搞一块了  造成了干扰!

版主

发表于 2017-8-30 12:44:18  
可能是电磁阀工作时产生的磁场干扰到传感器

实习生

发表于 2017-8-30 14:45:02    楼主|
我还在调试中,没有接电磁阀,只接了压力变送器,电磁阀的动作是通过指示灯来看的。

实习生

发表于 2017-8-31 15:54:26    楼主|
王栋春 发表于 2017-8-30 21:54
有图吗  上传一下 看看

你好!测试时气压显示异常的问题已经解决了,是程序的问题。
现在我把电磁阀、压力变送器和步进电机都接好了,但是每当电磁阀打开时,气压显示就有波动。比如,正常气压应该显示为500kPa,但是电磁阀一打开,气压显示就成了70kPa,不过马上就会恢复到500kPa,波形图上有异常波动。
我在测试程序时是没有这种情况的,会不会正如您前面所讲,是电磁阀的磁场干扰?如果真是这样,我该怎样解决?感谢您的多次回复!

工程师

发表于 2017-8-31 16:18:37  
rainjoy 发表于 2017-8-31 15:54
你好!测试时气压显示异常的问题已经解决了,是程序的问题。
现在我把电磁阀、压力变送器和步进电机都接好了,但是每当电磁阀打开时,气压显示就有波动。比如,正常气压应该显示为500kPa,但是电磁阀一打开,气压显示就成了70kPa,不过马上就会恢复到500kPa,波形图上有异常波动。
我在测试程序时是没有这种情况的,会不会 ...

个人认为:1、如王工所说产生了干扰
                2、因为没有你的结构图,所以只能猜想一下了,会不会在开的那一瞬间由于气流的扰动确实会发生变化

实习生

发表于 2017-8-31 16:55:49    楼主|
王栋春 发表于 2017-8-30 21:54
有图吗  上传一下 看看

你好!问题解决了,把压力变送器接到电磁阀前面就好了,电磁阀后面压力波动较大。谢谢你!

版主

发表于 2017-8-31 21:01:32  
rainjoy 发表于 2017-8-31 16:55
你好!问题解决了,把压力变送器接到电磁阀前面就好了,电磁阀后面压力波动较大。谢谢你!

的确如此    原来还真遇到过这种情况

实习生

发表于 2017-9-1 16:32:27    楼主|
将军问鼎 发表于 2017-8-31 16:18
个人认为:1、如王工所说产生了干扰
                2、因为没有你的结构图,所以只能猜想一下了,会不会在开的那一瞬间由于气流的扰动确实会发生变化

谢谢!正如您所说,确实是气流扰动引起的。我才看到您的留言,但是奖励积分我已经用过了,非常抱歉!

工程师

发表于 2017-9-1 17:18:25  
rainjoy 发表于 2017-9-1 16:32
谢谢!正如您所说,确实是气流扰动引起的。我才看到您的留言,但是奖励积分我已经用过了,非常抱歉!

没事没事,问题解决了就好
高级模式
您需要登录后才可以回帖 登录 | 注册

关闭

站长推荐 上一条 /8 下一条

快速回复 返回顶部 返回列表
-

推荐专区

技术干货集中营

专家问答

用户帮助┃咨询与建议┃版主议事

工程师杂谈

工程师创意

工程师职场

论坛电子赛事

社区活动专版

发烧友活动

-

嵌入式论坛

ARM技术论坛

Android论坛

Linux论坛

单片机/MCU论坛

FPGA|CPLD|ASIC论坛

DSP论坛

嵌入式系统论坛

-

电源技术论坛

电源技术论坛

无线充电技术

-

硬件设计论坛

PCB设计论坛

电路设计论坛

电子元器件论坛

控制|传感

总线技术|接口技术

-

测试测量论坛

LabVIEW论坛

Matlab论坛

测试测量技术专区

仪器仪表技术专区

-

EDA设计论坛

multisim论坛

PADS技术论坛

Protel|AD|DXP论坛

Allegro论坛

proteus论坛|仿真论坛

EasyEDA-中国人自已的EDA工具

Orcad论坛

-

综合技术与应用

电机控制

智能电网

光电及显示

参考设计中心

汽车电子技术论坛

医疗电子论坛

-

开源硬件

-

无线通信论坛

无线通信技术专区

天线|RF射频|微波|雷达技术

-

IC设计论坛

芯片测试与失效分析

Mixed Signal/SOC[数模混合芯片设计]

Analog/RF IC设计

设计与制造封装测试

-

厂商专区

TI论坛

TI Deyisupport社区

-

检测技术与质量

电磁兼容(EMC)设计与整改

安规知识论坛

检测与认证

-

消费电子论坛

手机技术论坛

平板电脑/mid论坛

音视/视频/机顶盒论坛

-

电子论坛综合区

聚丰众筹官方社区

新人报道区

聚丰供应链

-

论坛服务区

-

供求信息发布

供需广告

招聘┃求职发布区

电子展览展会专区